• Toll-free  888-665-8637
  • International  +1 717-220-0012
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Joel Gray
#1 Posted : Tuesday, November 08, 2016 1:14:23 PM(UTC)
Joel Gray

Rank: Member

Joined: 9/23/2004(UTC)
Posts: 18
United States
Location: Bend

Thanks: 3 times
We're trying to do an upgrade from BV Commerce 2015.1.1.1059 to BV 2017. After running the SqlPatch.aspx page, we're redirected back to the login page for /bvadmin as expected. When entering the same username and password that works from the original 2015 store we are not able to log in. The site simply redirects us back to the login page with no messages.

Browsing back to the home page does show categories and products in the navigation list and Top Sellers list, but product pages and category pages themselves are blank.

Environment
  • Server: Windows 2008 R2 Datacenter SP1
  • .NET Framework version 4.6.2 is installed.


Upgrade Process
  1. Copy existing 2015 database to a new datbase
  2. Create a new website for the upgrade process
  3. Copy new 2017 files into the new website
  4. Copy the connection string from the production site's web.config to the new site's web.config
  5. Browser to the hostname the new site is configured to use
  6. Click the button to update the databsae


Did I miss some other simple step somewhere? Is there more information that I can supply?

Thanks in advance
-Joel

Edited by user Tuesday, November 08, 2016 1:15:35 PM(UTC)  | Reason: Not specified

Aaron
#2 Posted : Tuesday, November 08, 2016 3:31:23 PM(UTC)
Aaron

Rank: Administration

Joined: 4/2/2004(UTC)
Posts: 2,273
United States
Location: Hummelstown, PA

Thanks: 6 times
Was thanked: 141 time(s) in 136 post(s)
Joel,

Have you checked the Audit Log for any errors? Given that you can't log in you would need to run a SQL query against the bvc_Audit table.
Aaron Sherrick
BV Commerce
Toll-free 888-665-8637 - Int'l +1 717-220-0012
Joel Gray
#3 Posted : Tuesday, November 08, 2016 3:39:28 PM(UTC)
Joel Gray

Rank: Member

Joined: 9/23/2004(UTC)
Posts: 18
United States
Location: Bend

Thanks: 3 times
I had not, but when I check the only records show that I've successfully logged in, yet I keep getting redirected to the login page.

id TimeStampUtc SourceModule ShortName Description UserId UserIdText Severity
373685 2016-11-08 20:36:47.263 3 Successful Login User <redacted> logged into the site. 1
373684 2016-11-08 20:36:29.047 98 System Startup System is starting up. SYSTEM 1
Aaron
#4 Posted : Tuesday, November 08, 2016 5:33:00 PM(UTC)
Aaron

Rank: Administration

Joined: 4/2/2004(UTC)
Posts: 2,273
United States
Location: Hummelstown, PA

Thanks: 6 times
Was thanked: 141 time(s) in 136 post(s)
For anyone else experiencing this issue after upgrading, this occurs if you have specified "Cookie Domain" and "Cookie Path" values in your site settings (Options >> Site Settings >> Security) that are different than the domain where you are currently running the site.

So, for example, if you are using production site settings and running the site on a development machine, you will not be able to log in until these values are either cleared (the default) or set to match your environment. Since you are unable to log into the admin you will need to do this via SQL and then restart the application after the change (e.g. recycle the app pool, bump the Web.config file, etc).

Here's a SQL query that you can run to clear the values:

Code:
UPDATE bvc_WebAppSetting
SET SettingValue = ''
WHERE SettingName = 'CookieDomain' OR SettingName = 'CookiePath'
Aaron Sherrick
BV Commerce
Toll-free 888-665-8637 - Int'l +1 717-220-0012
Joel Gray
#5 Posted : Tuesday, November 08, 2016 7:38:33 PM(UTC)
Joel Gray

Rank: Member

Joined: 9/23/2004(UTC)
Posts: 18
United States
Location: Bend

Thanks: 3 times
Thanks Aaron, I appreciate the quick response and resolution!
Damon
#6 Posted : Thursday, May 30, 2019 6:45:35 AM(UTC)
Damon

Rank: Member

Joined: 5/30/2019(UTC)
Posts: 8
United Kingdom

I know it's bad forum etiquette to necro a thread after such a long period BUT I am experiencing exactly this same problem as the OP after upgrading to Bvc 2018.1.1.2250.

Both CookieDomain & CookiePath are empty yet whichever method I use to try and login (either My Account sign in or Admin) I just get redirected back to the login page.

It's driving me nuts.

Any help would be greatly appreciated.

Damon.
Aaron
#7 Posted : Thursday, May 30, 2019 9:20:19 AM(UTC)
Aaron

Rank: Administration

Joined: 4/2/2004(UTC)
Posts: 2,273
United States
Location: Hummelstown, PA

Thanks: 6 times
Was thanked: 141 time(s) in 136 post(s)
Damon,

Did you previously have values set to the CookieDomain and CookiePath?

Can you query the Audit Log after attempting to log in to see whether your login was recorded? Also, are there any errors when you attempt to log in?

Lastly, try using Chrome Incognito mode to prevent the browser from caching any redirects.
Aaron Sherrick
BV Commerce
Toll-free 888-665-8637 - Int'l +1 717-220-0012
Damon
#8 Posted : Monday, June 03, 2019 5:26:01 AM(UTC)
Damon

Rank: Member

Joined: 5/30/2019(UTC)
Posts: 8
United Kingdom

Thanks Aaron,

it appeared to be a caching problem which is now sorted.
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

©2019 Develisys. All rights reserved.
  • Toll-free  888-665-8637
  • International  +1 717-220-0012