• Toll-free  888-665-8637
  • International  +1 717-220-0012
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

michael_b
#1 Posted : Tuesday, February 26, 2019 4:27:05 PM(UTC)
michael_b

Rank: Member

Joined: 2/3/2010(UTC)
Posts: 46

Thanks: 3 times
I was wondering if anyone else having the same issue. My last PCI scan failed because of some jQuery issue (please see attached screenshot). My BV store version is: 2018.0.1.2031. I also have an option to upgrade it to: 2018.1.1.2250 but not sure which upgrade I need since I see two of them. Will the newest version fix the jQuery issue? Thanks.
michael_b attached the following image(s):
new-version.JPG (54kb) downloaded 3 time(s).
PCI-error.JPG (66kb) downloaded 2 time(s).

You cannot view/download attachments. Try to login or register.
Aaron
#2 Posted : Wednesday, February 27, 2019 8:39:44 AM(UTC)
Aaron

Rank: Administration

Joined: 4/2/2004(UTC)
Posts: 2,251
United States
Location: Hummelstown, PA

Thanks: 6 times
Was thanked: 138 time(s) in 133 post(s)
Yes, PCI Compliance scans are now failing sites which use older versions of jQuery. We will be releasing an update in the future which will utilize a newer version of jQuery that is not susceptible to this vulnerability.
Aaron Sherrick
BV Commerce
Toll-free 888-665-8637 - Int'l +1 717-220-0012
michael_b
#3 Posted : Wednesday, February 27, 2019 9:49:37 AM(UTC)
michael_b

Rank: Member

Joined: 2/3/2010(UTC)
Posts: 46

Thanks: 3 times
Thank you for your prompt reply Aaron.

Just to make it clear:

1. Do I need to upgrade my store now or that will not fix the jQuery issue and the PCI scan will still fail for my site? If I have to upgrade now, do I need to upgrade it to "2018-SP1 upgrade" or "2018.1.1.2250" if my current version is 2018.0.1.2031

2. Wait for the next release?

Thank you.
Aaron
#4 Posted : Wednesday, February 27, 2019 2:09:23 PM(UTC)
Aaron

Rank: Administration

Joined: 4/2/2004(UTC)
Posts: 2,251
United States
Location: Hummelstown, PA

Thanks: 6 times
Was thanked: 138 time(s) in 133 post(s)
Originally Posted by: michael_b Go to Quoted Post
1. Do I need to upgrade my store now or that will not fix the jQuery issue and the PCI scan will still fail for my site?

Upgrading to 2018 SP1 will not resolve the PCI scan issue.

Originally Posted by: michael_b Go to Quoted Post
2. Wait for the next release?

TBD
Aaron Sherrick
BV Commerce
Toll-free 888-665-8637 - Int'l +1 717-220-0012
michael_b
#5 Posted : Tuesday, March 12, 2019 1:10:08 PM(UTC)
michael_b

Rank: Member

Joined: 2/3/2010(UTC)
Posts: 46

Thanks: 3 times
Anyone else getting PCI failed because of the jQuery issue?
michael_b attached the following image(s):
Failed-PCI-03-12-2019.JPG (61kb) downloaded 2 time(s).

You cannot view/download attachments. Try to login or register.
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

©2019 Develisys. All rights reserved.
  • Toll-free  888-665-8637
  • International  +1 717-220-0012