• Toll-free  888-665-8637
  • International  +1 717-220-0012
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

GHanlon
#1 Posted : Tuesday, April 24, 2018 3:04:09 PM(UTC)
GHanlon

Rank: Member

Joined: 2/24/2016(UTC)
Posts: 72
United States

Thanks: 8 times
I just created an order for a customer on the back end. They had Loyalty Points on their account, which were applied to the order total, and then subsequently debited as part of payment for the order, resulting in a new grand total owed. However, after clicking "Place Order" (selecting Payment by Phone as payment method), the original order total is shown as being owed. In the Private Notes on the order, is does show that the Loyalty Points were debited for the order, and their account no longer has any Loyalty Points. Is there something that we are missing? Or is this a bug?
Aaron
#2 Posted : Wednesday, April 25, 2018 7:55:38 AM(UTC)
Aaron

Rank: Administration

Joined: 4/2/2004(UTC)
Posts: 2,300
United States
Location: Hummelstown, PA

Thanks: 6 times
Was thanked: 146 time(s) in 141 post(s)
This isn't an issue that we're aware of. Please open a support ticket and provide the pertinent details (e.g. order number, etc) so that we can take a closer look. Thanks!
Aaron Sherrick
BV Commerce
Toll-free 888-665-8637 - Int'l +1 717-220-0012
Aaron
#3 Posted : Wednesday, April 25, 2018 5:27:57 PM(UTC)
Aaron

Rank: Administration

Joined: 4/2/2004(UTC)
Posts: 2,300
United States
Location: Hummelstown, PA

Thanks: 6 times
Was thanked: 146 time(s) in 141 post(s)
For everyone else, the outcome of this is what appears to be a bug affecting BVC 2018 and below; BVC 2018 SP1 has a fix for this. Note that this only occurs when placing an admin order for a customer that has loyalty points. The workaround for older versions is to impersonate the customer account and place the order on the frontend.
Aaron Sherrick
BV Commerce
Toll-free 888-665-8637 - Int'l +1 717-220-0012
GHanlon
#4 Posted : Friday, August 31, 2018 2:26:58 PM(UTC)
GHanlon

Rank: Member

Joined: 2/24/2016(UTC)
Posts: 72
United States

Thanks: 8 times
We just had a customer place an order on the front end, and they had Loyalty Points. Their card payment came through for all but the amount the Loyalty Points covered, and the payment history shows that their Loyalty Points were used. However, the order status is "partially paid", with an outstanding balance equal to the Loyalty Points used on the order. I know SP1 fixed this issue for admin orders, but looks like customer orders are now facing the same issue?
Aaron
#5 Posted : Thursday, September 06, 2018 12:39:47 PM(UTC)
Aaron

Rank: Administration

Joined: 4/2/2004(UTC)
Posts: 2,300
United States
Location: Hummelstown, PA

Thanks: 6 times
Was thanked: 146 time(s) in 141 post(s)
Does the order have a loyalty points payment on the order payments page? Also, are you seeing this issue with every order when a customer uses loyalty points?
Aaron Sherrick
BV Commerce
Toll-free 888-665-8637 - Int'l +1 717-220-0012
GHanlon
#6 Posted : Thursday, September 06, 2018 1:11:12 PM(UTC)
GHanlon

Rank: Member

Joined: 2/24/2016(UTC)
Posts: 72
United States

Thanks: 8 times
The Loyalty Points is noted in the Private Notes section:

8/31/2018 12:53:27 PM
[Charge] Success for order number 25031: Loyalty points debited for 1000 points ($10.00)
Amount: $10.00

When in the Payment tab for the order, the only payment shown was the credit card payment. We added an Offline payment option to explain the usage of the Loyalty Points to have the payment status switch from Partially Paid to Paid.
GHanlon
#7 Posted : Thursday, September 06, 2018 1:15:19 PM(UTC)
GHanlon

Rank: Member

Joined: 2/24/2016(UTC)
Posts: 72
United States

Thanks: 8 times
This is the first time a customer has placed on order on their end and had Loyalty Points in their account. We have nothing to go off of for reference if this is a one-time occurrence or a pattern.
Aaron
#8 Posted : Thursday, September 06, 2018 4:29:59 PM(UTC)
Aaron

Rank: Administration

Joined: 4/2/2004(UTC)
Posts: 2,300
United States
Location: Hummelstown, PA

Thanks: 6 times
Was thanked: 146 time(s) in 141 post(s)
Originally Posted by: GHanlon Go to Quoted Post
When in the Payment tab for the order, the only payment shown was the credit card payment.

That's the issue, and it sounds just like the bug that was fixed in 2018 SP1 (although that fix was supposed to only be for the admin).

Originally Posted by: GHanlon Go to Quoted Post
This is the first time a customer has placed on order on their end and had Loyalty Points in their account. We have nothing to go off of for reference if this is a one-time occurrence or a pattern.

I would do some testing to see if you can reproduce this. I tested this on our demo store and everything worked properly (see attached screenshots).
Aaron attached the following image(s):
vieworder.png (32kb) downloaded 3 time(s).
receivepayments.png (38kb) downloaded 3 time(s).

You cannot view/download attachments. Try to login or register.
Aaron Sherrick
BV Commerce
Toll-free 888-665-8637 - Int'l +1 717-220-0012
GHanlon
#9 Posted : Thursday, September 13, 2018 11:23:05 AM(UTC)
GHanlon

Rank: Member

Joined: 2/24/2016(UTC)
Posts: 72
United States

Thanks: 8 times
We had another customer place on order on the front end of the website, and this same issue occurred with their order. Loyalty Points are debited and show up as such in the Private Notes, but the order is "Partially Paid" and doesn't have any Loyalty Points showing up in the Payment tab. Seems like this isn't a fluke anymore for us.
Aaron
#10 Posted : Thursday, September 13, 2018 12:13:41 PM(UTC)
Aaron

Rank: Administration

Joined: 4/2/2004(UTC)
Posts: 2,300
United States
Location: Hummelstown, PA

Thanks: 6 times
Was thanked: 146 time(s) in 141 post(s)
What other payment method was used on these two orders?
Aaron Sherrick
BV Commerce
Toll-free 888-665-8637 - Int'l +1 717-220-0012
GHanlon
#11 Posted : Thursday, September 13, 2018 1:29:48 PM(UTC)
GHanlon

Rank: Member

Joined: 2/24/2016(UTC)
Posts: 72
United States

Thanks: 8 times
The first customer order with this issue (about two weeks ago) used credit card for the primary payment method. This most recent customer order with this issue used PayPal Express for the primary payment method.
Aaron
#12 Posted : Thursday, September 13, 2018 3:05:58 PM(UTC)
Aaron

Rank: Administration

Joined: 4/2/2004(UTC)
Posts: 2,300
United States
Location: Hummelstown, PA

Thanks: 6 times
Was thanked: 146 time(s) in 141 post(s)
Since we are unable to reproduce this on our demo store, and since your site has some customizations, I would speak with your development company to ensure that nothing was missed during a past upgrade or that nothing else might be interfering.
Aaron Sherrick
BV Commerce
Toll-free 888-665-8637 - Int'l +1 717-220-0012
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

©2020 Develisys. All rights reserved.
  • Toll-free  888-665-8637
  • International  +1 717-220-0012