• Toll-free  888-665-8637
  • International  +1 717-220-0012
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Steve95
#1 Posted : Wednesday, September 21, 2016 9:20:39 AM(UTC)
Steve95

Rank: Member

Joined: 4/29/2010(UTC)
Posts: 246

Thanks: 4 times
Was thanked: 11 time(s) in 10 post(s)
Just setting up a new site and I would like to enable Site-wide SSL support.

I have ensured that my Site Standard Root and the Secure Site Root are both https://mydomainname.com This seems to work for 99% of cases however occasionally when you hit any is still stays on http and continues to do so within that browser window.

I have Redirect to Primary Domain setup in the SEO section, but this does not seem to have any effect.

Do I need to enable url rewrite rules or should BV handle everything? Is there any other options to enable this feature? I am running Bvc 2015 SP2

Aaron
#2 Posted : Wednesday, September 21, 2016 10:36:28 AM(UTC)
Aaron

Rank: Administration

Joined: 4/2/2004(UTC)
Posts: 1,989
United States
Location: Hummelstown, PA

Thanks: 6 times
Was thanked: 108 time(s) in 103 post(s)
Steve,

Can you open a support ticket for this? Thanks.
Aaron Sherrick
BV Commerce
Toll-free 888-665-8637 - Int'l +1 717-220-0012
CM3 Solutions
#3 Posted : Monday, May 01, 2017 1:03:33 PM(UTC)
CM3 Solutions

Rank: Member

Joined: 8/20/2008(UTC)
Posts: 73
United States

Thanks: 2 times
Was there a solution to this? I am having the same issue. I am using version BV Commerce 2013.0.1.301
Aaron
#4 Posted : Monday, May 01, 2017 1:59:17 PM(UTC)
Aaron

Rank: Administration

Joined: 4/2/2004(UTC)
Posts: 1,989
United States
Location: Hummelstown, PA

Thanks: 6 times
Was thanked: 108 time(s) in 103 post(s)
Originally Posted by: CM3 Solutions Go to Quoted Post
Was there a solution to this? I am having the same issue. I am using version BV Commerce 2013.0.1.301

Site-wide SSL support wasn't added until BVC 2015 SP1. The bug that Steve encountered above was fixed with the BVC 2017 release.
Aaron Sherrick
BV Commerce
Toll-free 888-665-8637 - Int'l +1 717-220-0012
CM3 Solutions
#5 Posted : Monday, May 01, 2017 2:59:41 PM(UTC)
CM3 Solutions

Rank: Member

Joined: 8/20/2008(UTC)
Posts: 73
United States

Thanks: 2 times
2013.0.1.301 has a Redirector section. "Redirect to Primary Domain:" is set to Yes. Primary Domain is with the https.
Aaron
#6 Posted : Tuesday, May 02, 2017 8:24:30 AM(UTC)
Aaron

Rank: Administration

Joined: 4/2/2004(UTC)
Posts: 1,989
United States
Location: Hummelstown, PA

Thanks: 6 times
Was thanked: 108 time(s) in 103 post(s)
Originally Posted by: CM3 Solutions Go to Quoted Post
2013.0.1.301 has a Redirector section. "Redirect to Primary Domain:" is set to Yes. Primary Domain is with the https.

This is unrelated to the site-wide SSL functionality. The "Redirect to Primary Domain" setting is about the domain, not the protocol. Again, site-wide SSL support was added in BVC 2015 SP1.
Aaron Sherrick
BV Commerce
Toll-free 888-665-8637 - Int'l +1 717-220-0012
CM3 Solutions
#7 Posted : Tuesday, May 02, 2017 2:45:56 PM(UTC)
CM3 Solutions

Rank: Member

Joined: 8/20/2008(UTC)
Posts: 73
United States

Thanks: 2 times
I added the following to the web.config and it did the trick.

Code:
<system.webServer>
 <rewrite>
  <rules>
   <rule name="Redirect to https">
    <match url="(.*)"/>
    <conditions>
     <add input="{HTTPS}" pattern="Off"/>
    </conditions>
    <action type="Redirect" url="https://{HTTP_HOST}/{R:1}"/>
   </rule>
  </rules>
 </rewrite>
</system.webServer>
Steve95
#8 Posted : Thursday, May 04, 2017 9:55:17 AM(UTC)
Steve95

Rank: Member

Joined: 4/29/2010(UTC)
Posts: 246

Thanks: 4 times
Was thanked: 11 time(s) in 10 post(s)
Originally Posted by: CM3 Solutions Go to Quoted Post
I added the following to the web.config and it did the trick.

Code:
<system.webServer>
 <rewrite>
  <rules>
   <rule name="Redirect to https">
    <match url="(.*)"/>
    <conditions>
     <add input="{HTTPS}" pattern="Off"/>
    </conditions>
    <action type="Redirect" url="https://{HTTP_HOST}/{R:1}"/>
   </rule>
  </rules>
 </rewrite>
</system.webServer>


Just a quick note. For the above solution to work IIS will need to have the URL Rewrite module installed which is available from https://www.iis.net/down...ds/microsoft/url-rewrite


Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

©2017 Develisys. All rights reserved.
  • Toll-free  888-665-8637
  • International  +1 717-220-0012