Posted by Andrew on December 18, 2017

Critical PCI Compliance Security Changes

Comments (0)

The Payment Card Industry Security Standards Council (PCI SSC, or simply PCI) is enforcing a deadline for the transition to TLS 1.2.

All payment gateways, including Authorize.Net and PayPal, will require TLS 1.2. In turn, your site must support TLS 1.2 or you will be unable to process credit cards.

Other services, such as UPS, are also enforcing this requirement. If you recently experienced problems with UPS real-time rates on your store, this is likely the reason.

A non-exhaustive list of services and their TLS 1.2 enforcement dates:

  • Authorize.Net - February 28, 2018
  • PayPal - June 30, 2018
  • UPS - Began September, 2017; enforced December 31, 2017
  • USPS - June 22, 2018

BV Commerce 2017 and above support TLS 1.2. Older versions of BV Commerce do not. If your store runs a version of BV Commerce prior to the 2017 release, you must update to the latest version prior to the applicable enforcement dates to continue processing credit card payments.

Learn how to upgrade >>

Not sure what version you're running?

The version number is located in the header or footer of your store's admin, depending on the version of BV Commerce that you are using.

Questions?

Please contact us with any other questions you may have. 


Add comment

biuquote
  • Comment
  • Preview
Loading

©2018 Develisys. All rights reserved.
  • Toll-free  888-665-8637
  • International  +1 717-220-0012